Tuesday, September 16, 2008

BIB-7000 Cannot access X Server

We had this issue while we did 11.5.10.2 upgrade last week. It was a hectic weekend, but with help of my patner Apps DBA we made it easy and delivered the instance 11hrs before actual outage. So come to the issue. I have mentioned in of the my previous Post regarding Xvfb setup in our production env admin node. Display variable is working fine adnd we dint' have any issues with DISPLAY, but getting "BIB-7000 Cannot access X Server" message while accessing graphs in Workflow pages from OAM.
While investigating realized this error was coming from Application tier where we do not have setting for Display, or I can say was set to somewhere else which was not working. As we didn't want to run Autoconfig again, what we did. We changed DISPLAY variable in jserv.properties file to our admin node Display setting and bounce Apache. Vola it worked.

Happy Troubleshooting !!!

3 comments:

Divyanand said...

Good Suggestion......

It worked for me, there are two jserv.properties files to be update in IAS_ORACLE_HOME,
-- ./appsutil/template/Apache/Jserv/etc/jserv.properties
-- ./Apache/Jserv/etc/jserv.properties

Sundeep Dubey said...

Glad it worked for you too.

Gil said...

Hi this post was really helpful! Thanks. There can be, however, another piece to this. See Metalink doc 434827.1 for more info which references this same error BIB-7000. This is what the doc says and it fixed the problem for me (I also did your fix as well):
1) In OAM> SiteMap > System Configuration > AutoConfig > Edit parameters of Application Tier >
Select "Environments" > Expand "oa_environment:generic_service" > Search down for
"s_java_awt_headless" > Change from False to True > Save

2) Exit OAM

3) Shutdown Applications Services

4) Run AutoConig on All Nodes

5) Test OAM > Workflow Manager > Notification Mailer Again